[下载] Xshell 6.0.0118 + Xftp 6.0.0111 便携整合版

[复制链接]
查看237 | 回复1 | 2019.5.6 19:55 | 显示全部楼层 |阅读模式
基于官方原版制作便携版,下载解压后直接运行 Xshell6Portable.exe 或 Xftp6Portable.exe 即可,2019/3/9 更新版本为 Xshell 6 Build 0118 (6.0.0118)、Xftp 6 Build 0111 (6.0.0111) 简体中文绿色版。

鉴于 SSH/SFTP 工具的特殊性,请在使用 Xshell + Xftp 整合版之前详细阅读并明白以下提示:

请不要修改 Xshell6Portable.exe 和 Xftp6Portable 这两个程序的文件名,否则整合版会失效;
若运行报错或无反应,需要安装 VC 运行库:Visual C++ 2008 SP1 以及 Visual C++ 2012;
请务必另行备份好登录服务器需要的密码、Public Key 密钥及密钥密码,以免 Xshell 便携版发生异常导致配置丢失;
如果你要在另一台电脑上使用本便携版,保存的 Public Key 的密码会被重置,需要重新输入密钥密码,这应该是出于安全考虑;
便携版支持加载命令行参数,对 Xshell6Portable.exe 设置的命令行参数将在运行时传递给 Xshell 主程序;
Xftp 6 便携版也添加了命令行参数支持,对 Xftp6Portable.exe 设置的命令行参数将在启动运行时传递给 Xftp 主程序;
便携版不支持自定义会话文件夹路径,始终保存 Data\Settings 文件夹下,请不要在程序中修改;
运行结束后请务必正常关闭 Xshell/Xftp 主程序,以保持便携化,否则可能发生异常或混乱。


新版的 Xshell 或 Xftp 会在启动时弹出一个错误提示: Initialize Flexnet Service failed / Error code: 50003

这可能是新版 Xshell 需要 FlexNet Licensing Service 来验证授权 (Activation Licensing Service),而 Xshell 便携版并没有安装此服务,因此在启动时会弹出上面的错误提示,因为 Xshell 和 Xftp 对个人用户是免费授权的,所以不影响实际使用。

如果很介意 Error 50003 这个错误弹窗,请下载解压到一个目录,然后运行 !-Install.bat 脚本来安装服务,或运行 !-Uninstall.bat 脚本来卸载此服务。

XshellXftp6Portable.7z (22.16 MB, 下载次数: 6)
https://www.loadream.com
admin | 2019.5.17 12:48 | 显示全部楼层
terminal.png
https://www.loadream.com
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册账号

本版积分规则